Indy 10 Delphi 7 error ... "was compiled with a different version of" ...

Giganews Newsgroups
Subject: Indy 10 Delphi 7 error ... "was compiled with a different version of" ...
Posted by:  Douglas Eynard (eyna…@midwestls.com)
Date: Thu, 15 Sep 2005

I install Indy 10.
I was getting an like this one "IdSMTPBase was compiled with a different
version of IdEMailAddress.TIdEMailAddressItem" so I recomplied the compents
manually like the web site says below

Open and compile in the following order:
  1.. IndySystem (in Lib\System)
  2.. IndyCore (in Lib\Core)
  3.. IndyProtocols (in Lib\Protocols)
  4.. IndySuperCore (in Lib\SuperCore)
  If you are not using SuperCore, then you do not need to compile this
package.
Now open and click install in the following order
a..
  1.. dclIndyCore (in Lib\Core)
  2.. dclIndyProtocols (in Lib\Protocols)
  3.. dclSuperCore (in Lib\SuperCore)
  Only install this if you have compiled SuperCore.
And I still get this error "IdSMTPBase was compiled with a different version
of IdEMailAddress.TIdEMailAddressItem" message.  The error message really
doesn't make sence since both units our complied in the group.
What is going wrong?

Thank you
Doug

Replies