Re: Indy 10.1.5 install into Delphi 6

Giganews Newsgroups
Subject: Re: Indy 10.1.5 install into Delphi 6
Posted by:  adam (ad…@fmfoods.co.uk)
Date: Fri, 28 Apr 2006

Sorry, please ignore this post, there was an Indy60.bpl hidden away in my windows\system32 folder which was not being picked up by Windows Search because it did not include "Hidden" folders ... ouch. Having removed this Indy 10 installs fine.

ARRRGH.

> Sorry ... I am sure I ought to be able to fix this myself, but I am just com
> ing up against a brick wall.
>
> --
>
> Installing Indy 10.1.5 into D6, with Indy 10.0.xx on there before.
>
> I uninstalled *thoroughly* removing all BPLs DCPs, etc., as well as running
> the Indy uninstall.exe, deleting the whole directory tree for Indy 10. & fol
> lowing the other instructions with the install.exe
>
> Then I ran the indy10.1.5_d6.exe ...
>
> On opening Delphi I get the following messages:
>
> 1. "Procedure entry point IdGlobal@min$qqrxjxj not found.
>
> 2. Cannot load dclIndyCore60.bpl procedure cannot be found. Do you want to r
> eload this library next time you open delphi?
>
> .... then similar messages repeat for other lost procedures with IndySystem6
> 0.bpl or dclIndyProtocols60.bpl ...
>
> --
>
> I assumed it was because I had left some little traces of the old Indy insta
> llation around on my machine, & it was reading old versions of the BPLs whic
> h might be causing the conflicts, so I repeated the process 3 or 4 times, by
>  the end I even emptied the recycle bin of all the old Indy Components ... b
> ut I still get the same error messages.
>
> What am I doing wrong?
>
> Adam Brett

Replies

In response to

Indy 10.1.5 install into Delphi 6 posted by adam on Fri, 28 Apr 2006