Re: Was / is there a problem with Indy and a computer running for a long time?

Giganews Newsgroups
Subject: Re: Was / is there a problem with Indy and a computer running for a long time?
Posted by:  Mike B (mike_nospam@faribonet.net)
Date: Thu, 30 Jun 2005

Maybe this?

http://groups-beta.google.com/group/borland.public.delphi.internet.winsock/browse_frm/thread/3805f865489854a8/0fd2636ecb17654a?q=indy+uptime+delphi&rnum=3&hl=en#0fd2636ecb17654a

Mike

> I have a strange problem with a small app that does some server cleaning
> every night. It loads several files from an IBM pSeries (AIX) machine
> using FTP, and then archives the stuff and whatnot. The problem is, that
> after a given time (I haven't measured it but it seems to be a month or
> so), the FTP stops working - and it starts working again after restarting
> the (Windows) server it's running on.
>
> I seem to recall having seen a posting one time, where someone said there
> was a problem in Indy that had to do with the uptime of the computer it
> was running on, but now I can't find anything related to that. Can anyone
> help me: was there ever such a problem, and was it fixed or is there a
> workaround? If my memory is failing, any ideas as to what else could cause
> such problem?
>
> Pieces of the puzzle are: Indy 10.0.52, Delphi 2005 Pro, Windows 2000
> Server, and the ftp server is what came with AIX 5.1 running on IBM
> pSeries.

Replies

In response to

Was / is there a problem with Indy and a computer running for a long time? posted by Antti Kurenniemi on Mon, 20 Jun 2005