Put Blues

Giganews Newsgroups
Subject: Put Blues
Posted by:  ClĂ©ment_Doss
Date: Wed, 27 Feb 2008

Hi,

I am using Indy 10.2.3 and Delphi 7.

I just don't know how to solve this problem.
I must upload 2 files
  1) 12MB
  2) 13Mb

The problem is that the file get uploaded, but instead of returning "normally" it
raises a Read timeout error. I've monitoring, and in fact, the file gets uploaded,
but for some reason indy stand still till the timeout occurs (followed by Connection
closed by remote host).
I tried with DOS Ftp, and the same thing happens.
Using CuteFTP the file get update without any problems.
I talked to my ISP, and he said he did some testing and the file uploaded normally.

Here is the log

Stat Connected.
Recv 27/02/2008 14:06:39: 220 LocaSite FTP Server [ Bem Vindo ]<EOL>
Sent 27/02/2008 14:06:39: USER *****<EOL>
Recv 27/02/2008 14:06:39: 331 Password required for dhs.<EOL>
Sent 27/02/2008 14:06:39: PASS *****<EOL>
Recv 27/02/2008 14:06:39: 230 User ***** logged in.<EOL>
Sent 27/02/2008 14:06:39: FEAT<EOL>
Recv 27/02/2008 14:06:39: 211-Features:<EOL>
Recv 27/02/2008 14:06:40:  MDTM<EOL> REST STREAM<EOL> SIZE<EOL>211 End<EOL>
Sent 27/02/2008 14:06:40: TYPE I<EOL>
Recv 27/02/2008 14:06:40: 200 Type set to I<EOL>
Sent 27/02/2008 14:06:40: SYST<EOL>
Recv 27/02/2008 14:06:40: 215 UNIX Type: L8<EOL>
Sent 27/02/2008 14:06:40: TYPE I<EOL>
Recv 27/02/2008 14:06:40: 200 Type set to I<EOL>
Sent 27/02/2008 14:06:40: PASV<EOL>
Recv 27/02/2008 14:06:40: 227 Entering Passive Mode (***,***,0,62,138,77).<EOL>
Sent 27/02/2008 14:06:40: STOR www/downloads/tsm/v100/pt_br/tmInstallclient.exe.new<EOL>
Recv 27/02/2008 14:06:40: 150 Opening BINARY mode data connection for
www/downloads/tsm/v100/pt_br/tmInstallclient.exe.new<EOL>
Stat Disconnected.

The code is very simple :

  idFTP1.Connect;
  idFTP1.Put( File1, File1 );
  idFTP1.Put( File2, File2 );
  idFTP1.Disconnect;

Any Ideas?

TIA,
Clément

Replies