Strange problem with attached html

Giganews Newsgroups
Subject: Strange problem with attached html
Posted by:  Angelo Diego Crabolu (angelodie…@libero.it)
Date: Tue, 23 Mar 2004

When i send an EMail with :
    with TIdText.Create(IdMessage.MessageParts, nil) do
    begin
      ContentType := 'text/html';
      Body.LoadFromFile(appdir + FileName);
    end;
I got the html content changed, the original was
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<HEAD>
<TITLE></TITLE>
<META NAME="Generator" CONTENT="FastReport 2.4"/>
<META NAME="Author" CONTENT=""/>
<META NAME="Keywords" CONTENT="FastReport"/>
<META NAME="Description" CONTENT="The FastReport report"/>
<LINK href="a.css" rel="stylesheet" type="text/css" media="all">
<LINK href="a_print.css" rel="stylesheet" type="text/css" media="print">
<HEAD>
<div class = "page_break"></div>
<span class = "STL0" style = "left: 52px; top: 29px;">18165</span>
<span class = "STL0" style = "left: 100px; top: 121px;">0</span>
</BODY></HTML>

when i got the mail the html became:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<HEAD>
<TITLE></TITLE>
<META NAME=3D"Generator" CONTENT=3D"FastReport 2.4"/>
<META NAME=3D"Author" CONTENT=3D""/>
<META NAME=3D"Keywords" CONTENT=3D"FastReport"/>
<META NAME=3D"Description" CONTENT=3D"The FastReport report"/>
<LINK href=3D"a.css" rel=3D"stylesheet" type=3D"text/css" media=3D"all">=

<LINK href=3D"a_print.css" rel=3D"stylesheet" type=3D"text/css" media=3D=
"print">
<HEAD>
<div class =3D "page_break"></div>
<span class =3D "STL0" style =3D "left: 52px; top: 29px;">18165</span>
=<span class =3D "STL0" style =3D "left: 100px; top: 121px;">0</span>
</BODY></HTML>

Is there a bug in indy or what?
Regards, Angelo Diego Crabolu.

Replies