Re: Error send message using htm with embebed images

Giganews Newsgroups
Subject: Re: Error send message using htm with embebed images
Posted by:  Remy Lebeau (TeamB) (no.spam@no.spam.com)
Date: Thu, 13 Oct 2005

"Flavio" <diasflav…@yahoo.com.br> wrote in message
news:F2FFBD7ECCDDE240diasflav…@yahoo.com.br...

> I'm using delhi 7 and Indy 10.0.52.
>
> I'm finding troubles to send a HTML message with an embedded image.

You might want to read the following article, if you haven't already:

    HTML Messages
  http://www.indyproject.org/Sockets/Blogs/RLebeau/2005_08_17_A.iwp

> i'm using the TidSMTP component to do this. The conection is successed,
> but then i recieve an error when tring to send the message:

> Project SendMail.exe raised exception class EIdSMTPReplyError with message
>
> 'unimplemented (#5.5.1)

The server is reporting on error on its end.  Something TIdSMTP tried to do
is not implemented by the server.  It is hard to say what that could be,
though, without seeing the raw SMTP commands that TIdSMTP is sending.
Please use a packet sniffer, such as Ethereal http://www.ethereal.com), or
attach one of the TIdLog... components to TIdSMTP, to see the raw data that
is transmitted over the socket.

> // stat of message

When I try to view that message in OE, it does not work.  The image is
treated as a normal attachment and is not displayed in the message body.
Also, your image's Content-Type header is wrong.  The MIME type for JPEG is
"image/jpeg", not "image/pjpeg".

Gambit

Replies

None

In response to

Error send message using htm with embebed images posted by Flavio on Thu, 13 Oct 2005