attachment problem

Giganews Newsgroups
Subject: attachment problem
Posted by:  Pascal (coene…@gmaildotcom)
Date: Mon, 13 Jun 2011

Hi,

Having the following problem:

>Trying to use your software with the Box.net services(cloud storage).
>
> But when the mail arrives to box.net the attached can not be pulled
out of the mail.
>
> I have talked to box.net support and the answer with this.
> "Unfortunately it looks like they must be either changing the
destination email is such a way that our system does not know where to
direct it, or they are attaching the file in such a way that we are not
able to pull it out of the email."
>
> Is this an know issue or shuld I set up Limagito in a special way?

Any idea? I tried it myself with a mail account from my own isp
provider without any problem.

Code that I'm using is like the one I found in the newsgroup here:

var
MailBuilder: TIdMessageBuilderPlain;
MailMessage: TIdMessage;
SMTP: TIdSMTP;
begin
MailBuilder := TIdMessageBuilderPlain.Create(nil);
MailBuilder.PlainText.Text := 'Here is that thing you wanted.';
MailBuilder.Attachments.Add(filepath);
MailMessage := MailBuilder.NewMessage;
MailBuilder.Free;

MailMessage.Recipients.EMailAddresses := 'someo…@there.com';
MailMessage.From.Name := 'Me';
MailMessage.From.Address := '…@here.com';
MailMessage.Subject := 'Indy attachment sample';

SMTP := TIdSMTP.Create(nil);
SMTP.Connect(some_IP_Adress, 25);
SMTP.Send(MailMessage);
SMTP.Disconnect;
SMTP.Free;

MailMessage.Free;
end;

Best Regards,
Pascal

--

Replies